Announcement

Announcement Module
Collapse
No announcement yet.

PC to Synscan Controller to EQ6 mount communications problems

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • PC to Synscan Controller to EQ6 mount communications problems

    I have started to experiment with software control of my EQ6 goto mount via SkyX software on my laptop. The problem comes with the RS232 communications between the PC and the Synscan controller handpiece.

    To test the PC to RS232 link I have set the communications bite rate (9600baud with the appropriate 8 bit no parity and 1 stop bit) and neither the PC with the software or a terminal program in place of the SkyX software running on the on the PC will communicate or get any response from the Synscan controller (in PC mode) attached to the mount. From this one would suspect a communications failure or hardware issues. Testing RS232 echo on the cable works as well so the PC in terminal mode is sending characters.

    The other night using the PC and the same serial interface and cables I updated the Synscan firmware from version 3.23 to 3.25 (Skywatcher downloads) using the default 115kb speed for updating. This worked perfectly so I assume from this success communications works well albeit with a speed difference.

    I have downloaded the latest pdf update to the Synscan manual and this mentions the 9600 bit rate and the basic commands to send to the handset control as well as the return from the Controller '?' to the control and a '#' returned.

    Has anyone else had success or found the trick to make this work with PC to Synscan Controller RS232 communications when the Synscan controller is in the PC control mode? The skywatcher site offers very little detail here.

    When the hardware arrives I will be trying PC to EQ6 direct.

    I would appreciate any assistance, David

  • #2
    David welcome to the site.

    I think your problem is software based. SkyX is the new version of Sky6 and I know there are some bugs with that software to synscan mount configuration. Something to do with the software not supporting ASCOM.

    I know the SkyX programming team are releasing a patch or updater for this program but I am not sure if it is out yet (or even if that will fix your issue) but I would be checking that out first before spending too much time on your cables etc. There are known issues with that software and mount. Not sure where to download the update patch though.

    Ray

    Comment


    • #3
      Yes you are right, Skyx has a bug. Some people went back to Sky6 because of it.

      Pete

      Comment


      • #4
        Hi David

        Apparently you must have the correct cable as otherwise you would not have been successful in upgrading the HC

        I use a "Serial/USB" convertor plug between the PC and the programming serial cable to the mount because my lappy has no serial ports - the Prolific or FTDI ones works fine - I have also discovered that ALL convertors are NOT the same!!

        I use this method sometimes with EQMOD and Sky6 and it has always worked flawlessly for me - I actually no longer use the handcontroller since the EQDIR cable I built worked right off controlling the mount thru the Sky6 with a wireless gamepad (Saitek one works fine) - the only reason I sometimes use PC-Direct mode is that I am just running a short session

        I do not use SkyX however I presume you would know how to set the option from within SkyX to get it to communicate with the mount - I believe the ASCOM-compatible mount's DLL is available from the website but what the others have stated seems to be more of a software "bug" problem than anything else and I noted that Bisque says to connect the SkyX to the mount using NexStar 5

        Perhaps a look into EQMOD might be beneficial

        BTW my HC is also v3.25 - HTH and that I use Windows XP Pro and NOT Vista which gave me some grief at one stage when I used the other lappy!

        Cheers
        Bill

        Comment

        Working...
        X